OpenKM freezes on startup

Symptoms

OpenKM freezes during the startup process. The system seems to be waiting for some event and becomes frozen, but it does not raise any exception even in debug mode.

Cause

When OpenKM is configured with OpenOffice, it needs to start an instance in order to work with it. However, especially in Windows systems, if the system is not shut down properly, it could block the OpenOffice process and prevent a new instance from being created.

Diagnosis

Looking at openkm.log file located at $TOMCAT_HOME/logs, you will see the system become stuck at some point, like:

2016-08-30 18:26:36,190 [localhost-startStop-1] [] INFO c.o.util.antivirus.AntivirusFactory - Initializing Virus detector

On Windows Server, download the Process Explorer application from:

And execute it, looking for running instances of OpenOffice. You should find one or more of them.

Solution

Using the utility mentioned above, kill all processes related to OpenOffice. Once there are no more running OpenOffice processes, start OpenKM again and it will be able to create new instances.

Properties

Properties

Date

2016-08-30

Applies to

  • Administration
  • Frontend
  • Core
  • Web services
  • Third-party software integration
  • OpenKM Apps