NullPointerException when executing any workflow

Symptoms

When any workflow is executed, a NullPointerException error is always raised.

Cause

JBPM tables were not created correctly during the first startup process. JBPM no longer supports HSQLDB (Hypersonic database).

Diagnosis

Check whether tables with names starting with JBPM_* exist in your database.

Solution

You must switch to another database (MySQL, PostgreSQL, Oracle, SQL Server, etc.) that works properly with JBPM.

Properties

Properties

Date

2016-07-31

Applies to

  • Workflows

Keywords

  • AllVersions
  •