UI takes a long time to load after a huge import or export
Symptoms
After a huge import or export, the frontend performance decreases and the loading process seems stalled for several seconds until it can be completed.
Cause
When you import or export documents, they are registered in the OKM_DASHBOARD_ACTIVITY table. This table is used by the Dashboard view to list the most recently created or modified documents. A huge number of records in this table can decrease login performance.
There's a crontab task named "Dashboard Activity Purge" that daily cleans dashboard logs older than 3 months. Check that you have enabled it.
Possible causes:
- Huge import.
- Huge export.
- Periodic (daily) imports or exports. The "Dashboard Activity Purge" crontab task only purges logs older than three months.
- The crontab task "Dashboard Activity Purge" is stopped.
Diagnosis
Check the number of records in the OKM_DASHBOARD_ACTIVITY table.
select count(*) from OKM_DASHBOARD_ACTIVITY;
Solution
Clean entries from OKM_DASHBOARD_ACTIVITY based on user (who imported or exported documents) or date.
Clean based on user ID:
DELETE FROM OKM_DASHBOARD_ACTIVITY WHERE DAC_USER = 'okmAdmin';
Clean based on date:
DELETE FROM OKM_DASHBOARD_ACTIVITY WHERE DAC_DATE < '2016-06-21 00:00:00'
Properties
Properties | |
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Date |
2016-07-27 |
Applies to |
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Keywords
- AllVersions